Editing tableview cells

Does anyone know why that when editing the tableview NSTextField (e.g. from page 167 when editing a name) the editing focus ring has a smaller width than the column or field width ? I tried a few size settings and constraints but had no luck in making it wider (i.e. to match the name column width)
Any thoughts?

I see the same thing–and if I add a long name, the TableView will use only a portion of the entire width of the column to display a truncated name.

I worked out that clicking on the NSTextField, there is an option to increase by dragging one of the little square cell delimiters to the right towards the end of the cell width
I can’t upload a screenshot unfortunately

With a Table Cell View selected in the Document Outline, I can see a single little square in the middle of the column, but I am unable to drag it to the right. I can drag it down, but not to the right.

What is the name of the thing selected in the Document Outline when you drag the square to the right? Okay, I got it: Table View Cell. And because that has a slider icon next to it, it is a control, and in this case it’s the NSTextField. So by dragging one of the little squares surrounding the text, you are resizing the width of the NSTextField to match the width of the TableView’s column. By default, the NSTextField’s width is only wide enough to fit its default text: “Table View Cell”.

Note that the raise column has the same problem–but you won’t notice it unless you enter a really big raise!

Thanks for posting your solution cookies. :slight_smile: