Error Message help: Cannot GET /


#1

Hey,

I’m trying to use browsersync through command line to view my html, css, and .js file on the browser directly. The command I’m using is:

browser-sync start --server --browser “Google Chrome” --files “.html, stylesheets/.css, scripts/*.js”

Unfortunately on the browser end, it’s showing “Cannot GET /” and a URL of localhost:3000

I’m not sure why this is happening. Any suggestions would be greatly appreciated!

Best :slight_smile:


#2

anyone out there that can help?


#3

UPDATE this worked for me:

Just wanted to post this in case anyone else ran into a similar issue. I was getting a “cannot get /” error when launching Browser-Sync in Google Chrome on Mac OS Sierra.

I’d simply receive “cannot get /” when loading localhost:3000.

What solved the problem for me was I wasn’t running browser-sync in the correct directory. When I changed the working directory to ottergram/ everything worked fine. In retrospect, of course that was the issue :wink:.

Hope this helps someone else.


#4

Thank you for your post,
I’ve been all morning trying to solve this issue :slight_smile: now it works!