I can't execute given source code

When i open project from the given zip file i have no configuration. After adding it i have no module. Okay there is some message in the event log:

12:36 Frameworks detected
Android framework is detected.

“Configure” is a button. After pressing it, some module appears. I’m choosing it and see “Error: AndroidManifest.xml doesn’t exist or has incorrect root tag” below. I found info that i need to press “sync project with gradle files” button, but i have not it (when i open my own project i have it).

I tried to invalidate caches. The button has not appeared, but now the event log has a new message:

13:00 Migrate Project to Gradle?
This project does not use the Gradle build system. We recommend that you migrate to using the Gradle build system.
More Information about migrating to Gradle
Don’t show this message again.

The button “More Information about migrating to Gradle” talks about how to migrate project from eclipse or intellij to android studio. But this project was created in android studio from the outset.

I also tried to use gradlew.bat in console, i get:

FAILURE: Build failed with an exception.
*What went wrong:
Could not determine java version from ‘17.0.2’.

What do i have to do to run the project from this zip file.


Where did you get the solutions? If you are trying to run old solutions (for the 3rd edition of the book) in a newer version of Android Studio, you might run into some issues.