Navigation bar objects won't change color

Wondering if anyone else encountered this. I’m guessing this is a bug in Xcode. I’m using MacOS 11.3.1 and Xcode 12.5.

After the book instructs us to change the Global Tint color, there are two UI elements in the app that won’t change color in Interface Builder. But they do change color as expected when you run in simulator. These are the + and < LootLogger buttons.

In my screenshot, see how I have set the Global Tint color to red, but those two buttons are still blue. Yet the camera button in the tab bar is red. I can force the + button to change by selecting that Bar Button Item in Interface Builder and setting its Tint color. But I can’t find an equivalent way to do that for the < LootLogger button. And anyway I don’t think you should have to do that because the Global Tint color should propagate to all those buttons.

I tried rebooting Xcode & my Mac, I tried toggling between different devices/appearances/orientations in Interface Builder, but no dice. And I noticed the same problem exists when I checked the project that was provided for this lesson in Big Nerd Ranch’s solutions files, so I don’t think it’s due to a mistake I made in my project.

I guess it’s not a big issue since the colors work as expected when you run the app. But it’s just odd that this is jacked up in Xcode.