Problem with the Android Virtual Device

I am not sure i can ask this question on this forum, but i would like to make use of the AVD to experiment with different kind of devices (tablet,phone,…) . I can’t figure the solution to the following annoying problem. I searched the net and tried the proposed solutions which worked for some, but none worked for me so far. As it seems, there is not a unique solution. I get the message:

Emulator Panic: Cannot find AVD system path. Please define ANDROID_SDK_ROOT.

Why hasn’t this been taken care of by the installation program? Why do i to fix this? Doesn’t android studio already know the path to such a critical directory? Please explain to me in laymen terms why i have to set this up? Any helop would be appreciated.

I will reply to my question, because i found the solution. I read the official documentation, this page more precisely:
I changed the ANDROID_HOME variable so it points to the correct path where the sdk resides on my local hard drive (system properties, advanced settings, environment variable). I copied the path from the SDK Manager -> Android SDK (copied the path shown on the right of the screen)

Take away point for me: think about about reading the official documentation.

I’m giving you back a point. I agree, why didn’t the setup procedure include that as a step or at least inform you somehow. Plus, one could argue launching the emulator from the studio might not need an environment variable, it could be passed somehow or temporarily set, like possible in .bat files. I’m going through setup and spent a day trying to locate and troubleshoot “enabling VT-X” in my computer boot ROM so the emulator wouldn’t complain. These things sure add up when you are starting out. But thanks for pointing out the link to the doc, just collecting authoritative and up-to-date docs is proving to be a necessary task.