Problem with x-select in Tracker New Sighting

First of all thank you for writing this excellent book. I am an experienced developer but new to web development and Java Script. This book is just what I was looking for It was like having a mentor.
I got all of the examples working up until chapter 24. When I load the New Sightings page I am getting the following error from x-select
ember.debug.js:26513 TypeError: _this.get(…) is not a function
at x-option.js:71
at invokeWithOnError (ember.debug.js:9037)
at Queue.flush (ember.debug.js:8923)
at DeferredActionQueues.flush (ember.debug.js:9086)
at Backburner.end (ember.debug.js:9165)
at (ember.debug.js:9244)
at Backburner.join (ember.debug.js:9257)
at$1.join (ember.debug.js:26895)
at Class.hash.success (rest.js:622)
at fire (jquery.js:3317)

I am using emberx-select@3.1.0
I am using ember-cli@2.14.0
I am using ember-data@2.14.5

Anyone else seeing this problem?

Hi @dmaynard, I think that is this issue o’er here, give it a shot and let me know if that solves it!


Yes that worked. Thank you, and thank Todd!

David Maynard

Problem solved with an existing answer in the errata:

Install EmberX-Select p.437

Thank you!