Screen is completely black after build/run following Figure 4.10


#1

I am not sure what happened but it after I deleted ViewController and created ConversionViewController, I made all the connections as instructed, but not when I build the program, the simulator screen is completely black. I even used the Hardware functions to press the home key, and you see the World Trotter icon.

I even deleted ConversionViewController and started that section all over again. I still get the same thing. Has anyone else come across this?


#2

Maybe you can try

Product -> Clean then Product -> Build at the top menu.

If that doesn’t work, when you did the File -> New -> File and saved a new Swift File on bottom of page 74. Did you get this same result?

I think the ConversionViewController is supposed to be in the WordTrotter group instead. In this case, delete the file again and make sure when you File -> New and save that you click within the WordTrotter project and click within the Wordtrotter group until it shows up in the WordTrotter group in the figure above. (I had to repeat this a second try to get in the proper group)

I’m hoping this will fix your problem and it won’t hurt to give it a try. I think this was the cause for my problem which is mentioned in another thread.


#3

I tried both of these solutions and neither one worked. I still get a black screen when the app runs.
I will try to redo the whole section again and see what happens.

…Now it works, not sure what I did different, but it is solved.

Thanks for your input.


#4

It is likely due to absence of Storyboard Entry Point (i.e. no Initial View Controller).
In storyboard, select the view controller. At the attributes inspector, in View Controller section, Check Is Initial View Controller.