The Decimal Pad error. Help

Hi guys, I wondered whether you could help me… I get the following error when running the simulator, I click on the Text Field to enter text and whilst the keyboard comes up, everytime I get printed as output:

Can't find keyplane that supports type 8 for keyboard 
iPhone-PortraitChoco-DecimalPad; using 

If I click on the background and then click on the Text Field again it will do exactly the same. I’m completely new to Swift and programming in general, I’ve looked elsewhere and couldn’t find a solution. It’s very annoying. Any help’s appreciated. Thanks.

I get the same error when invoking the keyboard by clicking in the text field.

Hi there,

OK, had the same problem, just worked it out (xCode 8.3.3 here). When connecting the outlet from Conversion View Controller to the ‘100’ celsius label, do it from the hierarchal menu left of the canvas to the ‘100’ label. When connecting the Editing Changed sent event, control-click from the circle next to Editing changed to the Conversion View Controller in the same hierarchal list left of the canvas - NOT the yellow circle on the canvas as depicted in the book (v6).