Using Atom Beautify requires tweaks - set Pretty Diff

Using Atom Beautify (Click Packages==>Atom Beautify==>Beautify) did nothing at first. I needed to make a tweaks.

Navigate: File==>Settings==>click Packages==>click settings under atom-beautify

Under Default Beautifier, select Pretty Diff

For convenience, put checkmark by selecting Beautify On Save

Click x to close the setting window.

Now your html file gets indented properly upon a Save.