Chapter 21 Extensions
A minor point which doesn't affect the code, but irritates the physicist in me.
Velocity is used as a type alias for Double. Velocity is then used to set up a variable topSpeed.
However, speed is a scalar, not a velocity. Velocity is a vector with magnitude and direction.
Velocity should be renamed Speed.
I should also say that it is a great book. It's renewed my enthusiasm for learning Swift.