If you have trouble getting ZIPspector to run


#1

I know I’m slow a lot of the times, and I miss obvious things. That is probably the case here. I built ZIPspector making all the corrections needed to use Swift 4.1 and clicked run in Xcode. It ran and then nothing happened. As I said, I’m slow so I tried this a few times, closing the project, reopening, rerunning it. Nothing. I couldn’t figure out how this program would know where to look for a zip file to inspect.

I tried my own advice I gave to Mark in a previous chapter, deleted the project and rebuilt it, thinking I missed something. Nope, same results.

I was all set to ask for help on here again, when I noticed at the top of the screen the menu items for ZIPspector (I have one of those big ThunderScreens from Apple at home for docking my laptop… my excuse for taking so long to notice this way up in the top!). I know I should have known the menu items for ZIPspector would be there, they’ve been there with previous exercises. As I mentioned, sometimes I’m slow.

Anyhow, clicked on file, clicked on open…, then clicked on a zip file. Guess what, it worked. Duh!