MacOS Kindle beachballs when opening Book

Hello, I purchased the Kindle version of iOS Programming (7e) recently and am not able to open it on the MacOS version of the Kindle app. After opening your book in the app, it beachballs indefinitely until manually killed. I have tried using 3 different computers (all beefy mbp’s less than 2 years old), and have tried the Apple App Store version of Kindle, as well as the download version of the Kindle app, all with the same result. I can open any other book just fine. I can use your book just fine on Kindle for iPad, so this appears to be related to MacOS Kindle only. I’d appreciate any help with this. Thank you!

1 Like

Hey @jranson Thanks for bringing this to our attention. We are actively looking into this and will get back to you when we have more information to share. Thanks again!

I see exactly the same thing on my 2019 MBP.

I resorted to standing my iPad next to the computer when working through the book.
That’s ok, but makes it much harder to copy text (although I suspect that might be cheating :grinning:).


Small update – We have been able to reproduce the issue with the Amazon Kindle version of the book. We’ve tested the file that we send to Amazon and it does not have problems, so it seems that something went wrong on Amazon’s side when they apply their DRM and upload it to their servers.

We are reaching out to Amazon to work on resolving the problem.

In testing, what we’ve noticed is that the book is usable once it is open. But certain interactions – such as tapping the Library button, showing the Table of Contents, and changing the font size – cause the Kindle app to beachball. As was noted in the original post, this is limited to the iOS Programming book; other books do not have this issue.

We’ll post an update once we are able to chat with Amazon. Thanks again!

Small update. We have shared all of the information with Amazon tech support, and they are working on the issue. We are still waiting on a resolution.

I am also having the same problem (early 2015 MacBook Pro with macOS Catalina). Even trying to access the TOC forces me to quit the Kindle macOS application.

Regardless if the issue is solved, is it possible to get an ePub version of the book (or even a PDF)? I find iBooks to provide a better performance, be more robust and overall provide a better feature set than Kindle on macOS (and iPad).

Just an FYI to anyone still having an issue with this - today Amazon released v1.30 of the MacOS Kindle App. I found that I am able to freely navigate through the iOS Programming book without any issues when using this new app version. Finally!


I confirm that on my side the issue is gone after the 1.3 Kindle update :+1: