Warning when installing auto-complete-paths Atom plugin

Howdy folks!
Just a quick question:-
When installing the auto-complete-paths plugin in the atom text editor I run across the following warning message pop-up.

> Maximum file count of 2000 has been exceeded. Path autocompletion will not work in this project.

Has anyone experienced this, and if yes how did you resolve it?.

Any insight is appreciated. Thanks.