Compile time too long


I know this question doesn’t belong here but I need help to figure out a solution to this problem because Apple support hasn’t responded yet.

Version 9.0 beta 5 (9M202q)
MacBook Pro (13-inch, Early 2011)
macOS HighSierra version 10.13.1 (17B48)

Every time I compile a program in Xcode it takes atleast 7 minutes to simulate the application. Around 90% of attempts, the program doesn’t even compile inspite of generating a successful build. Common error messages that show up are the following :
Could not attach to pid : "1050"
Failed to initiate service connection to simulator

Can anyone please help me ?

Warm regards.

Hi Sujay, the current version of Xcode is 9.1. If Apple responds, they will tell you to update to the latest version of Xcode to fix the problem. Once you have upgraded, you may also need the info in this thread, based on the age of your machine:


Hello Sue,

Thanks a lot for taking the time to answer my question. I have tried both versions of Xcode, Xcode 9.1 and Xcode 9.2 beta. No improvement in compile time in both cases. I tried to run the patch mentioned in the above thread in my terminal but unfortunately it hasn’t solved the problem.

It’s frustratingly difficult to learn how to program in these conditions and the absence of Apple developer support doesn’t help at all. Thanks for your help anyways. All the best.


Sujay, I work on a 2011 Mac Mini . It just occurred to me that in order to make that even doable, I had to up the memory to 16 G and replace the factory hard drive with an SSD. Otherwise I would have had to toss the machine. You are on High Sierra - do you have an SSD in the machine? I am on Sierra, not ready to risk the filesystem changeover yet. It’s definitely possible to run Xcode on your machine - I also have a 2011 Macbook Pro with the same memory/SSD modifications that can also do it acceptably.


Hello Sue, Sorry for the delay in replying. I don’t have an SSD in my MacBook Pro. I am sceptical about making hardware changes to my machine just to program in a particular language or SDK. It means that programming in this language is not sufficiently accessible to everyone. This could be the wrong conclusion but so far Apple hasn’t proved it so.

Putting an SSD might end up being expensive and if it still doesn’t work, I would have wasted time and money on this quest. My last resort is to program in Kivy and build mobile projects with that platform. Hopefully I can circumvent the problem that way.

Thanks for taking the time to help me.

Warm regards.