Problem localizing Localizable.strings to Base in Xcode 9.1


#1

On page 138, we’re asked to localize Localizable.strings to Base; however, when I open the file’s file inspector and click Localize, I am not given this option.

I tried working around it by adding the Localizable.strings file to the Base.lproj folder in Finder, but I still didn’t have any luck once I added the Localizable.strings file to Xcode.

Here’s a screenshot of the only two localization options listed for the file.

Anyone know another way to make this work?

P.S. I do have “Use Base Internationalization” selected under Project > Info > Localizations, if that’s relevant. (screenshot below)


#2

I was actually able to complete this task by Localizing the Localizable.strings file to English, then to Spanish (by clicking the checkbox next to it):

localize%201

Then finding the Localizable.strings file with the disclosure triangle next to it in the Project Navigator and clicking on it. With it highlighted, I opened the File Inspector, and Base was then an option for localization.