What am I doing wrong in Xcode?

I’m working through chapter 32 and I’ve gotten to where OI"m supposed to hook up the button. In the Document Outline I don’t have a section called “Placeholders” at all so I don’t have a “File’s Owner”. The thing that’s closest is “Application Scene” and under that there are Application, App Delegate, and First Responder.

I’ve tried quitting out of xcode and restarting as well as making a new fresh project. Same result. This is Xcode 6.1.

I’d appreciate any help to get unstuck on this.


It looks like you have created a project that uses storyboards.

Try creating a new project with the Use storyboards option turned off; also make sure that you choose Objective-C as the language to use.

You nailed it…Thanks man!

I think that Use Storyboards may have been checked from something I previously worked on and it defaulted to on.

Also this is definitely a difference in the latest XCode over the screenshots in the book. There is not a ‘use storyboards’ checkbox in the screenshot in the book.

Thanks again for getting me unstuck.

I am using Xcode 8.3.3 and I see no option for Use storyboards when creating a project. I’m guessing that the Cocoa project template uses storyboards by default now. This is a problem for this chapter since there is no Placeholders or File’s Owner in the Document Outline. How should we connect the table view?